Contents

Introduction
Command window .................................................................................................................................................. 1
Menu ................................................................................................................................................................. 2
Image window ..................................................................................................................................................... 2
Phasor window .................................................................................................................................................... 2

Setting up HySP software
Harmonic ............................................................................................................................................................. 3
Open the image .................................................................................................................................................. 3
Open Phasor window ......................................................................................................................................... 4

Phasor processing
Filter ................................................................................................................................................................. 5
Range controls .................................................................................................................................................. 5
ROI selector ...................................................................................................................................................... 5
Zoom ............................................................................................................................................................... 6
3D image ........................................................................................................................................................... 7
Cursor ............................................................................................................................................................... 7
iROI Selector .................................................................................................................................................. 7

Saving images
Save image ......................................................................................................................................................... 9
Save phasor plot ............................................................................................................................................... 9
Save polygons .................................................................................................................................................. 9

SEER visualization
Maps ................................................................................................................................................................. 10
Modes .............................................................................................................................................................. 10
Save volume image ....................................................................................................................................... 10
License and support

HySP and SEER follow the University of Southern California and Translational Imaging Center Software License available here (http://bioimaging.usc.edu/license.html).

These instructions were written by Wen Shi and Francesco Cutrale at University of Southern California on 2019-03-30.
Introduction

HySP is a multi-platform software for analyzing multi-dimensional data. The application here uses hyper- and multi-spectral datasets. The software calculates a 2D phasor plot which can be analyzed interactively with ROI selectors, both phasor-to-image and image-to-phasor. The denoising algorithm improves the quality of data by reducing the poissonian noise.

The SEER module provides a robust way to spectrally interpret and visualize lengthy datasets. SEER is a pre-processing visualization approach for hyper- and multi-spectral fluorescent images. The technique is incorporated in the HySP software platform, a multi-platform software for analysis of multi-dimensional spectral data. SEER provides rapid enhanced visualization of spectral datasets, starting from fluorescent data.

Command window

After opening HySP software, the command window shows as below.
Menu

- Open image
- Open a series of images
- Close HySP
- Save Image Volume
- Save i/ROI Phasor as template

Image window

- Image average
- Change Z position
- Change Timepoint
- SEER maps
- SEER modes
- SEER sub-modes
- SEER reference map on phasor plot
- Phasor coordinates for Manual scale maps
- Enable iROI function
- Initialize image
- Zoom in/out
- Add iROI selector on image
- Save 2D Image
- Save 3D volume visualized above
Phasor window

Setting up HySP software

Harmonic

In the command window, under Phasor Settings the harmonic number can be typed. (i.e. harmonic:1; default configuration is 2)
Loading images

As of now HySP supports .lsm and .tiff files. Tiff files should be in a single tiff sequence or multiple multi-layer tiff files. NOT all layers in a single tiff file. Example: if dataset has shape [time, z-stack, channel, x, y] then it should be saved as one multi-layer tiff for each channel or each z-stack [t, :, ch, :,] , or [t, z, :, :,].

1. Open .lsm file
Click Show Image > choose the file (file in .lsm format) > click Open .
File > Open LSM >choose the file (file in .lsm format) > click Open .

2. Open generic .tiff file
File > Open Tiff Series > set up Tiff Series Details window.
Detailed info on dataset shape can be set in the window as below, parameters can be edited according to user’s data.

Adjust to your TIFF dataset

Check Advanced Setting if single image has multiple Z-frames/λ channels
Open Spectral Phasor window

On to the commend window > Click Calculate Spectral Phasor.
The phasor window shows as below.
Working with Phasors

Filter
Click Filter Data/SDenoise to reduce noise in phasor plot. This step can be repeated up to 10 times to improve phasor quality.

Range controls
Type in Minimum Value, Maximum Value > Click Update Plot to view fluorescent pixels in interested range.

Here is a comparison of filtering and range controlling

Before

After

Scale controls
Select Log-Phasor checkbox to visualize the phasor in log-scale. Click Update Plot to update window.

ROI controls
Select Use Alpha-Intensity checkbox to represent ROI phasor selection as an alpha-overlay on top of the image in Image Window. This visualization mode creates a colormap black-to-[color of ROI] and maintains the intensity of the underlying pixel. Generally useful for visual representation/rendering. Use Alpha-Intensity applies to all the ROIs added after the checkbox selection. Default mode (uncheckd Use Alpha-Intensity) is a solid color represenation.
ROI selectors

Rectangle

Rectangle ROI selector can acquire the coordinates in Cursor Info window; Click Add ROI selector > Choose the options, i.e. Rectangle > Click OK > Choose the color > Click OK > Move the rectangle on phasor.

Note: The phasor window and the image window can be viewed the same time to see the phasor chosen by rectangle is in which part of specimen in image. The specimen in image will be marked the same color user has chosen for rectangle in previous step.

Step1. Add ROI Selector
Step 2. Selector color

Step 3.

Rectangle ROI selector

Phasor Window

Image Window
Click Add ROI selector > Choose the options, i.e. Polygon > Click OK > Choose color > Click OK > Right click to move the polygon; Left click inside polygon close to vertices to change the shape.
Loading Saved Polygons

Click Load Saved Polygons and load previous polygons as template.

Navigating Phasor plot

Zoom
Click Zoom, frame the region surrounding the area of interest and zoom into it. Click Zoom again to lock the region in case the phasor plot moves.

Home
Click Home to get the original zoom factor.

Pan
Click Pan to translate S and G direction on the phasors.
3D datasets \([z, \lambda, x, y]\) and 4D \([t, z, \lambda, x, y]\)

Scroll Z-position in Image Window to visualize the chosen volume slice in dataset. Scroll Timepoint in Image Window to change time position in dataset.

Cursor info

For rectangle ROI and iROI, center coordinates are reported in >Cursor Window.

iROI selector

This option enables an ROI selector on the Image (rather than on the phasor). The \((S, G)\) values of each pixel selected on the image are then reported on the phasor according to the modality selected. E.g. average \((S, G)\) with std for G and S axis.

In Image Window Choose enable iROI > Click iROI options and choose (i.e. iROI avg on top) > Click on iROI > Choose cursor options (i.e. Polygon) > Select color (red as default) > Click OK > Move polygon on interested area > Statistics are reported on Cursor Info tab and in Phasor plot in Phasor window.

Note: Multiple polygons can be added on image with different colors, the area selected is labelled the same color in Phasor plot.
The iROI selector is represented with the same color on top of the phasor plot.

**Step 1:** Click **Enable iROI**

**Step 2:** Click **iROI**

**Step 3:** Click **Add iROI selector**

**Step 4:** Click **OK**

*default setting is iROI avg on top*

i.e. Click **Polygon**

The iROI selector is represented with the same color on top of the phasor plot.
Note: To load a new image and acquire the phasor of that image, you need to close all the windows and reopen HySP

**Saving Data, ROIs and Images**

**Save Data**
Processed data can be saved as .TIFF multilayer files by pressing File > Save Volume.. > Save Image Volume..
Each channel will be saved as a separate file. Each file will contain an entire z-stack if present. Multiple timepoint will contain t__ in filename

**Save ROIs**
ROIs selections on phasor can be saved by pressing File > Save i/ROI Phasoe.. > Save ROI Phasor as..
The file saved can be then reloading on a different dataset by clicking on Add ROI in Phasor Window and selecting Load ROI.

**Save Images**
Each image can be saved as a color picture (*.png). On Phasor Window > Save Image.. will save the phasor canvas with ROIs as currently visualized.
On Image Window > Save Image.. will save the image currently represented in the image canvas.
SEER Visualization

SEER Maps

After loading data and applying denoising, return to the Image window and on the bottom left click on the dropdown menu labeled “Grayscale” and the different SEER options of Gradient ascent, descent, radius, angle, and contour will appear.

SEER Reference Maps

Toggle the Map Reference checkbox, corresponding reference map will be updated on phasor window.
Modes

The “Mode” dropdown menu is right below the SEER map menu. The initial value is set as “Original Maps” and there are “Scaled Mode” and “Morphed Mode” available.

Scale Mode

Under Scaled mode there are auto-scale and manual scale mode.

Manual Scaled mode:

Selecting “Scaled Maps” will enable the sub-modes for this mode.

Step 1: Select SEER Scale Mode

Step 2: SEER sub-modes for Scale Mode
One can type in the G/S values to specify the reference map position on phasor plot, click **Update SEER** to scale and relocate the map reference on phasor plot. See figure below.

### Morph Mode

Under Morph mode, there are Max Morph mode, Mass Morph mode, and Manual morph mode. As an example, selecting **Morphed Maps** in the “Mode” dropdown menu will activate the different Morph modes in the drop down right below.
Manual Morph mode

Select **Morphed Maps, Manual Morph Maps** to activate manual morph mode. Click **Start**.

Mouse double click on phasor plot to morph the map reference to a new center, (G, S) coordinate of this new center is also updated when mouse released.
To explore the dataset, one can always switch to another map under any mode and sub-mode.

Step 3: Double Click red dot on phasor plot to shift the reference map to a new center.

Phasor coordinates of the new center are updated accordingly.
Save volume image

Click Save Seer Volume will yield a series of Tiff files in a name required folder for future processing, i.e. 3D rendering.